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Atividade Prática
http://www.youtube.com/watch?v=B-GVkJJof3o

 Tarefa 16: Botões para Controlar Animação

 Criar mais 2 camadas e renomeá-las
 Camada1 = botoes
 Camada2 = animacoes
 Camada3 = acoes

 Selecionar a camada botoes: desenhar 3 botões
 Textos dos botões: Iniciar, Parar, Voltar
 Formatar cores, bordas, fonte
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Atividade Prática
http://www.youtube.com/watch?v=B-GVkJJof3o

 Tarefa 16: Botões para Controlar Animação

 Selecionar o botão Iniciar (todo botão: forma e texto)

 Converter em símbolo:
 Nome = btn_iniciar
 Tipo = button

 Fazer nos demais botões:
 Parar: nome = btn_parar
 Voltar: nome = btn_voltar
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Atividade Prática

 Tarefa 16: Botões para Controlar Animação

 Selecionar o botão Iniciar
 Painel Propriedades > Instance Name

 Nomear as instâncias dos 3 botões
 Inst_btn_iniciar, inst_btn_parar, inst_btn_voltar

 Ctrl + Enter (só pra ver que já são botões)

 O nome da instância é o que será usado na linguagem 
ActionScript na hora de se referir ao botão.
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Atividade Prática

 Tarefa 16: Botões para Controlar Animação

 Dois cliques no botão Iniciar (ver slide 8)

 Over > F6 > Mudar cor do botão ou do texto ou da borda
 2 cliques fora do botão

 Fazer os mesmos passos com os outros 2 botões

 Ctrl + Enter
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Atividade Prática

 Tarefa 16: Botões para Controlar Animação

 F6 no frame 30 na camada botoes: bloquear a camada

 Frame 1 da camada animacoes: desenhar uma figura

 F6 no frame 30 e mover a figura (na camada animacoes)

 Create Classic Tween na camada animacoes
 Mudar trajetória da figura
 Clicar no frame desejado e mudar a figura de lugar
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Atividade Prática
http://www.youtube.com/watch?v=ZD-ZF-5agRw
http://www.youtube.com/watch?v=VyHYYQXwPYo

 Tarefa 16: Botões para Controlar Animação
 Selecionar a camada acoes (bloquear as outras camadas)
 Window > Actions (F9)
 Clicar no frame 1 da camada acoes

 Digitar as ações dos botões: ActionScript

 Aplicar som ao botão (dentro do modo edição do botão):
 Window > Common Libraries > Sounds
 Clicar com o botão direito = play: para ouvir o som
 Arrastar o som escolhido para cima do botão (Ctrl+Enter)
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Botões

 Up: botão em seu estado normal, sem a 
proximidade do mouse

 Over: estágio em que o usuário passa o mouse 
sobre o botão

 Down: instante em que o usuário está clicando 
no botão

 Hit: área clicável do botão, que não é
visualizada pelo usuário

 Voltar ao slide 5
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ActionScript 3.0

 É uma linguagem de programação orientada a objetos (OO) 
baseada em ECMAScript, utilizada principalmente para 
construção de aplicações Internet.

 É executada em uma máquina virtual (AVM - ActionScript 
Virtual Machine), atualmente na versão 3 que está disponível 
no Adobe Flash Player (plug-in encontrado em navegadores 
web) e também no ambiente Adobe AIR (Adobe Integrated
Runtime). 

 Adobe AIR é uma tecnologia que permite a criação de 
aplicações a partir de tecnologias de desenvolvimento de 
páginas web, como HTML, Ajax ou Flash. 
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ActionScript 3.0

 Lançado em Junho de 2006, em conjunto com o 
ambiente de desenvolvimento Adobe Flex 2.0 e o Flash 
Player 9.

 ECMAScript é uma linguagem de programação baseada 
em scripts, padronizada pela Ecma International na 
especificação ECMA-262 (European Computer
Manufacturers Association). A linguagem é bastante 
usada em tecnologias para Internet, sendo esta base 
para a criação do JavaScript/JScript e também do 
ActionScript. 
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ActionScript 3.0

 É obrigatória a declaração de variáveis, funções e 
seus valores retornados, até mesmo quando a função 
não retorna valor algum. 

 Exemplo de código em AS 3:
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ActionScript 3.0
 Os programadores JavaScript não terão grandes dificuldades 

para se adaptar à programação ActionScript. São grandes as 
semelhanças entre elas devido ao uso do padrão ECMAScript
(Ecma-262). 

 Em ActionScript, é recomendável separar cada linha do código 
por um ponto-e-vírgula (;). Não é obrigatório, mas no entanto é
extremamente recomendável para separar comandos. Além do 
mais, diferentemente da versão 2.0, o ActionScript 3.0 não 
permite tipagem fraca: todas os tipos de variáveis devem ser 
declaradas (tipagem forte). Exemplo:
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ActionScript 3.0

 Toda função deve ter um valor com que irá retornar, 
mesmo que seja um valor vazio (void). Por exemplo:
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ActionScript 3.0

 Todos os comandos de uma função, cláusula 
condicional, loops, classes e pacotes devem estar 
inseridos dentro de chaves ({ }). 

 A identação não é obrigatória, mas é extremamente 
recomendável, assim como na maioria das linguagens.

 Variáveis e funções não devem ter nomes que iniciam 
com números, nem com os caracteres "_" ou "$".
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ActionScript 3.0

 Os comentários são úteis tanto para inserir lembretes 
e informações sobre o código como para tirar linhas de 
código que numa compilação não sejam executadas 
(útil para testes).

 Há duas maneiras de comentar em ActionScript:
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ActionScript 3.0
 Além do conhecido Adobe Flash, há outras IDEs (Ambiente de 

Desenvolvimento Integrado) que permitem a programação de 
ActionScript. A maioria deles são gratuitas. Dentre as mais conhecidas 
podemos citar:

 Flex Builder: feita para os programadores tradicionais interessados em desenvolver 
para a Plataforma Flash. Não é apenas um editor de script, pois inclui vários 
componentes de interface de usuário (UI) e classes indisponíveis para Flash (mas 
disponíveis no Flex SDK). Feita para a criação de RIAs (Rich Internet Applications). 

 FlashDevelop: IDE gratuita, com vários recursos que agilizam a criação, e código 
aberto para Windows, construída sobre Microsoft .NET Framework. Para criação de AS 
em versão 2 e 3, também é possível criar HTML, CSS e outras. Com auto-complete e 
outros recursos. 

 SE|PY: editor gratuito para Windows e Mac, desenvolvido em Python por Alessandro 
Crugnola, originalmente para AS 2.0, mas também permite edição de AS 3.0 e 
JavaScript. 

 PrimalScript: criada pela SAPIEN Technologies, suporta mais de 40 linguagens para 
criação, incluindo HTML/CSS, JavaScript, Java, C#, Flash e Flex, Python, Ruby, Perl, 
entre muitas outras. Funciona por um período de teste de 45 dias. 

 Notepad++: mais limitado para uso de AS, é um editor de texto mais avançado que o 
Bloco de Notas do Windows, por exemplo. Permite coloração de sintaxe AS e de outras 
linguagens. 
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ActionScript 3.0
 Tipos de variáveis no ActionScript:

 Number: qualquer número, incluindo os de ponto flutuante (exemplo: 4.5)

 int: qualquer número inteiro, positivo ou não (452, -32...)

 uint: número inteiro e não negativo (2,487,0...)

 String: para textos ("olá", "Fulano Beltrano")

 Boolean: valor booleano (true ou false)

 Array: Registro de um ou mais valores ([25,"Fulano",54.47])

 Object: A estrutura básica de qualquer valor ActionScript, pode ser usado 
também como alternativa ao tipo Array - ser usado como um dicionário 
(meuObj.nome = "Fulano"). 
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ActionScript 3.0

 Para declarar uma variável:

 Não é preciso configurar um tipo de codificação 
(Unicode, ANSI, etc.) em ActionScript: ele trabalha de 
maneira tranquila com caracteres e acentos como 
cedilha (ç), til (~), pois, por padrão, utiliza o Unicode, 
que é uma especificação que reconhece caracteres 
latinos, japoneses, russos, entre outros. Para alterar a 
codificação, basta ir em:

Edit > Preferences > ActionScript (na IDE Adobe Flash)
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ActionScript 3.0

 Constantes

 No AS 3.0 foi introduzido o conceito de constantes, 
que nada mais são do que valores com um valor fixo 
e imutável.

 Por convenção (e não obrigação) é comum declarar 
constantes com nome em letras maiúsculas.
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ActionScript 3.0

 A declaração if é uma das mais comuns. Também 
podem ser usadas as declarações else if e else. 
Exemplo:
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ActionScript 3.0

 Operadores de comparação:
 Igualdade:  ==
 Não-igualdade: !=
 Maior:  >
 Menor:  <
 Maior ou igual:  >=
 Menor ou igual:  <= 

 Operadores lógicos:
 Operador E:  &&
 Operador OU: || 
 Operador de negação (false): !
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ActionScript 3.0
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ActionScript 3.0
 switch

 Há a opção switch, que é um modo de comparação mais 
simplificado e leve que o if, porém não pode ser usado para 
comparações complexas.

 Em vez de if, esta condicional utiliza a palavra case para sinalizar 
uma comparação. 

 E no fim de cada comparação é necessário inserir a palavra 
reservada break, senão todos os comandos serão lançados até o 
fim do switch (causando erro de comparação). 

 A palavra default executa uma ação caso nenhuma das 
comparações tenha sido bem-sucedida. 
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ActionScript 3.0
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ActionScript 3.0

Na primeira linha do loop criamos uma variável especificamente para o 
loop (no caso, i).

Logo após, fazemos uma comparação: se i for menor que 10, iremos 
executar trace(i.toString()) e também incrementaremos o valor de i (i++).

O i++ traz o mesmo resultado que i = i+1. Ou seja, ele incrementa 1 a cada 
iteração. Há também a possibilidade de subtrair: através de i--.

for: loop para executar ações de acordo com uma condição.
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ActionScript 3.0
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ActionScript 3.0

É preciso ter cuidado: é muito fácil errar com este tipo de loop, porque 
se você não fizer nada para tornar a expressão false ele irá repetir a 
operação infinitamente, o que poderá fazer o seu programa travar (caso 
do exemplo anterior). Para fazer o loop parar, é só fazer a expressão 
tornar-se falsa. Exemplo:
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ActionScript 3.0

Funções podem conter parâmetros ou não. E podem retornar em 
determinados tipos (String, Number...) ou não (retornando void).



29

ActionScript 3.0

Se você quer que uma função retorne um valor em um determinado 
tipo, esse tipo de dado deverá ser discriminado depois do sinal de 
dois pontos (:). Exemplo:
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Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 23

 Tarefa 17: Botões para Controlar Animação e Abrir Site

 Criar mais 2 camadas e renomeá-las
 Camada1 = botoes
 Camada2 = animacoes
 Camada3 = acoes

 Selecionar a camada botoes: desenhar 2 botões
 Textos dos botões: Animar, Google
 Formatar cores, bordas, fonte
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Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 23

 Tarefa 17: Botões para Controlar Animação e Abrir Site

 Selecionar o botão Animar (todo botão: forma e texto)

 Converter em símbolo:
 Nome = btn_animar
 Tipo = button

 Fazer o mesmo no botão Home:
 Google: nome = btn_google



32

Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 23

 Tarefa 17: Botões para Controlar Animação e Abrir Site

 Selecionar o botão Animar
 Painel Propriedades > Instance Name

 Nomear as instâncias dos 2 botões
 inst_btn_animar, inst_btn_google

 Ctrl + Enter (só pra ver que já são botões)

 O nome da instância (ocorrência) é o que será usado na 
linguagem ActionScript na hora de se referir ao botão. Instância é
uma cópia do objeto.
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Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 23

 Tarefa 17: Botões para Controlar Animação e Abrir Site

 Na camada animacoes
 Fazer as animações desejadas

 Clicar no frame 1 da camada acoes = F9
 Digitar as ações em ActionScript
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Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 31

 Tarefa 18: Criar Aplicativo do ActionScript

 File > New  =  ActionScript File
 Digite as ações

 File > Save = selecione o local e o nome do arquivo
 Nome = greeter.as



35

Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 31

 Tarefa 18: Criar Aplicativo do ActionScript

 File > New  =  Flash File (ActionScript 3.0)
 Ferramenta Texto: faça um campo de texto
 Ferramenta Free Transform: 300 px X  100 px
 Ferramenta Texto: tamanho, cor, tipo de letra

 Painel Propriedades
 Instance Name = mainText
 Dynamic Text



36

Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 31

 Tarefa 18: Criar Aplicativo do ActionScript

 No frame 1  = F9
 Digitar o código script

 Salvar o arquivo = helloworld.fla
 Salvar no mesmo local do arquivo greeter.as
 Ctrl + Enter
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Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 31

 Tarefa 18: Criar Aplicativo do ActionScript

 Abrir o arquivo Greeter.as
 Digitar o código script

 Abrir o arquivo helloworld.fla
 Clicar no frame 1 = F9
 Modificar o script
 Ferramenta Texto
 Desenhar 2 campos abaixo do mainText existente
 No primeiro campo = User Name:



38

Atividade Prática
Apostila Adobe: Programação do ActionScript 3.0 – Pág. 31

 Tarefa 18: Criar Aplicativo do ActionScript

 Selecionar o segundo campo: Painel Propriedades
 Input Text
 Instance Name = textIn
 Behavior = Single Line

 Clicar no frame 1 e digitar as ações
 Salvar e testar
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Atividade Prática
http://www.youtube.com/watch?v=RyjPwI89An0&feature=related

 Tarefa 19: Menu Animado

 Renomear a camada para home
 Desenhar um retângulo: ver posição e medidas
 Selecionar o retângulo: converter em símbolo 
 Movie Clip – Nome = home

 Entrar no modo edição do MovieClip: dois cliques
 Camada1 = retângulo1
 Camada2 = retângulo2
 Na camada retangulo2: desenhar um retângulo da 

mesma altura do outro, mas mais escuro e na mesma 
posição
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Atividade Prática
http://www.youtube.com/watch?v=RyjPwI89An0&feature=related

 Tarefa 19: Menu Animado

 Camada retangulo1 = frame 20 = F6
 Camada retangulo2 = frame 10 = F6 e frame 20 = F6
 Camada retangulo2 = frame 10

 Ferramenta Free Transform: aumentar retângulo escuro
 Clicar no frame 1: botão direito = copiar frame
 Clicar no frame 20: botão direito = colar frame
 Botão direito entre os frames: Create Shape Tween
 Entre o frame 1 e 10 e também entre o 10 e o 20
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Atividade Prática

 Tarefa 19: Menu Animado

 Camada retangulo2: clicar no frame 1 = F9
 Digitar: stop();
 Fazer o mesmo no frame 10

 Inserir nova camada = texto
 Ferramenta Texto: digitar Home (em cima do retângulo)
 Frame 20 = F6
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Atividade Prática

 Tarefa 19: Menu Animado

 Voltar para cena 1
 Selecionar o objeto todo: F9 (digitar o script)

on (rollOver){
gotoAndPlay(2);

}
on (rollOut){

gotoAndPlay(11);
}
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Atividade Prática

 Tarefa 19: Menu Animado

on (release){
getURL(“http://fit.faccat.br”)

}


